News Archive

FPDI release under the MIT License2015-10-13

We have changed the license of FPDI from Apache Software License, Version 2.0 to the MIT License as of FPDI version 1.6.0.

The Apache Software License, Version 2.0 is sadly not compatible to e.g. the GPL 2.0 because it has some requirements that are not in that GPL version. Because several open source projects rely or stuck on this GPL version and some of them are already using FPDI, we did the step to bring this issue to a neat solution by making the license of FPDI compatible.

If you are aware of or involved in any GPL 2.0 project that is using FPDI please update to 1.6.0 as soon as possible!

Check the release notes of the component below.


Version 1.6.0

Release date: 2015-10-12
  • Switch from Apache Software License, Version 2.0 to MIT License.
  • Added integer cast in ASCII85 filter for PHP 7 compatibility reason.