Find answers to frequently asked questions and read through some tips and tricks related to all Setasign PHP products.

choose category

Error: This document (xxx.pdf) probably uses a compression technique which is not supported by the free parser shipped with FPDI.

By default FPDI can "only" handle PDF documents up to PDF version 1.4. Beginning with PDF version 1.5 there were new compression features introduced which involve internal structure changes how a PDF document can be created.

We offer a parser replacement as a separate commercial addon, which enables FPDI to handle documents that uses these compression features.

Alternatively the document you're trying to import has to be resaved to PDF 1.4.